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TRADEMARKS 

All the brand names and other products or services mentioned in this document are identified by the trademarks or 

service marks of their respective owners. 

 

DISCLAIMER 

The information in this document is subject to change without notice and should not be construed as commitment 

by Reliance Jio Infocomm Ltd. Reliance Jio Infocomm Ltd. assumes no responsibility or makes no warranties for 

any errors that may appear in this document and disclaims any implied warranty of merchantability or fitness for a 

particular purpose. 

 

Summary of Changes: 

The Document Author is authorized to make the following types of changes to the document without requiring that 

the document be re-approved: 

a. Editorial, formatting, and spelling 

b. Clarification 

To request a change to this document, contact the Document Author or Owner. 

Changes to this document are summarized in the following table in reverse chronological order (latest version 

first). 

Revision Date Created By Short Description of Changes 

1.0 22nd Mar 2013 Garima Singh 
 Documenting the steps for developer registration 

and API subscriptions 

1.1 23rd Dec 2013 Garima Singh 

 Updated portal links for different environments and 

steps to import certificate for Android/iOS and 

application clients 

1.2 22nd Sept 2015 Omkar Acharya 
 Updated screenshots reflecting new developer 

portal v3.0 and added steps to how to access API 

1.3 1st Oct 2015  Omkar Acharya 

 Updated the Screenshots (Bordering the 

Screenshots) and added steps to how to send 

invitation to Developers. 

1.4 15th Jan 2016 Omkar Acharya 
 Revised FAQs based on queries from partner 

developers 

1.5 18th Jan 2016 Atul Rustogi  Formatting changes  
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1 Introduction 
This chapter identifies the document and the engagement to which it relates, describes the contents of the 
document, and states its purpose. 

1.1 Purpose 

This document provides a guide to developers who would like to build mobile apps using APIs exposed via Jio API 
platform. It is primarily meant for  

 Outlining steps that should be followed by developers before consuming any APIs exposed via Jio API 
Platform 

 Providing important URLs and key contacts for partner developers for approval & issues 

1.2 Intended Audience for this Document 

This document provides necessary details for developer onboarding and application lifecycle for developers and 
architects interested in understanding or working programmatically with Reliance Jio APIs. 

1.3 Organization of this Document 

The Develoepr guide is divided into six chapters summarized below: 

 Section 1 Introduction introduces Developer Guide for internal and external partner for Jio, identifies its 
intended audience, and explains the purpose and organization of the document. 

 Section 2 Developer registration outlines the steps required to signup on API Developer portal. 

 Section 3 Create Application covers the steps required to furnish necessary details for the applications. 

 Section 4 Adding APIs outlines the steps for adding/removing APIs for existing application 

 Section 5 Invoking API talks about the header information that is mandatory for accessing APIs exposed via 
Jio API platform 

 Section 6 Appendices documents the supplementary details. 

1.4 Important URLs & contacts  
  

Extrenal Partner 
Environment 

Jio Environment URL Portal admin contact 
details 

Integration ST https://stportal.ril.com/ Rjil.secoapidev@ril.com   

QA SIT https://sitportal.ril.com/ Rjil.secoapidev@ril.com  

Production Production https://developers.ril.com/ Rjil.topsseco@ril.com  

 

https://stportal.ril.com/
mailto:Rjil.secoapidev@ril.com
https://sitportal.ril.com/
mailto:Rjil.secoapidev@ril.com
https://developers.ril.com/
mailto:Rjil.topsseco@ril.com
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2 Developer registration 
The following chapter of the guide provides reference material for the Developer registration process. 

2.1 Sign up for a developer account 

Use this API to retrieve basic information of the Product based upon list of Service ID 

2.1.1 Home page > Sign up 
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2.1.2 Click Next  

 

 

Provide additional details and click Register Now when done. The Title in the additional information section 
signifies the name of the Organization (for eg: Name of the company in which developer is working) and 
Description section signifies the additional data about the organization. 

 

1. Registration request will be sent to Developer portal admin for approval. 
2. Once registered, drop a mail to Developer portal admin to approve registration and application. 
3. Once approved, your id is activated and you can log into the developer portal. 

2.2 Invite developers of your organization  

In the sign-up step 3.1, an organization is created for a developer and the person who registers first from the 
organization becomes the organization admin. Post approval of his account, he can send invitations to developers 
in his/her team. 
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The developer(s) after receiving the email will also have to register on the portal. But they will not be required to 
give details for the organization during the registration. Developer(s) then can create application(s) in the admin’s 
organization who has sent them the invitation. 
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3 Create application 
After successful registration on the required portal, an organization gets created on the portal with your registered 
credentials 

3.1 Manage Applications > Add application 

 

 

3.1.1 Add Application > Application Information 

 

This tab is meant for capturing basic information about the application – Name, supported mobile platforms & 
Description  
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3.1.2 Add Application > Additional Info 
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3.1.3 Add Application > API Management 

 

 

 

In the API Management section, you need to select the desired API from the Add API’s select box and accept the 
terms and Conditions and save the selected API. 
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3.1.4 Add Application > Auth 

Use this tab to specify details that will be used in OAuth based authentication flow.  

 

Callback URL: This is require only in case of 3 lagged OAuth. Ignore this field for partners that are advised to use 
service account. 
  
Scope: Agent (Partners which are supposed to use the service account) 
 

 

3.2 Organization > Create application 

Refer section 4.1 for steps  



API Platform developer guide 

 

Confidential | 12 

 

3.3 Application > Pending approval 

 

After the created application is saved, it appears within your organization with Approval Pending as shown in the 
snapshot given below. For application approval, please API portal admin of the respective environment. After 
approval you can use the API key which appears in front of the application. 
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4 Adding APIs 
New APIs will not be accessible to applications by default. Below steps are required in order to make these APIs 
available to applications 

4.1 Manage Applications > Application > Edit 

 

 

 

4.2 Manage Applications > Application > Edit > API Management 
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If you do not find desired API (published in the API guide) in Add APIs list, then contact API developer portal admin 
team for clarification. 
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5 Invoking APIs  
After creating an application, use the API key assigned to the application to access the API exposed by Jio API 
platform. 

1. Use the header for using the API key as X-API-Key. 

2. The value of the header is the value of the API-key. 

Example: X-API-Key: l7xxd7xxxxxxxxxxxxxxxxxxxxx (Note the case) 
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6 Appendices 

6.1 Appendix A – Export certificates from browser 

 

URLs for Jio API gateways (External partners)  
 
Integration (Jio internal env - ST) https://api-st.ril.com:8443/  

QA (Jio internal env - SIT) https://api-sit.ril.com:8443/  

Production https://api.ril.com/  

 

1. Go to respective environments API gateway link and download the certificate from browser. 

E.g. in Chrome browser, click on the lock sign in the address bar > Go to Connection Tab > Click on Certificate 
Information link 

 

 

 

2. Next Click on Details Tab > Copy to File > Accept all default and save the certificate. 

https://api-st.ril.com:8443/
https://api-sit.ril.com:8443/
https://api.ril.com/
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6.2 Appendix B – Import certificate and key 

6.2.1.1 iOS Client 

You should install the SSL distribution certificate and private cryptographic key you obtained earlier on the 
server computer on which the provider code runs and from which it connects with the development or 
production versions of APNs. To do so, complete the following steps:  

1. Open Keychain Access utility and click the My Certificates category in the left pane. 

2. Find the certificate you want to install and disclose its contents. 

You’ll see both a certificate and a private key. 

3. Select both the certificate and key, choose File > Export Items, and export them as a Personal 
Information Exchange (.p12) file. 

4. Servers implemented in languages such as Ruby and Perl often are better able to deal with certificates 
in the Personal Information Exchange format. To convert the certificate to this format, complete the 
following steps: 

a. In KeyChain Access, select the certificate and choose File > Export Items. Select the 
Personal Information Exchange (.p12) option, select a save location, and click Save. 

b. Launch the Terminal application and enter the following command after the prompt: 
openssl pkcs12 -in CertificateName.p12 -out CertificateName.pem -nodes 

5. Copy the .pem certificate to the new computer and install it in the appropriate place. 

Reference - 
https://developer.apple.com/library/ios/documentation/NetworkingInternet/Conceptual/RemoteNotifications
PG/Chapters/ProvisioningDevelopment.html  

6.2.1.2 Android Client 

1. Once you have the .keystore file and passphrase file, embed .keystore file in asset folder of 
application 

2. Write java code to read .keystore file using the passphrase. Sample java code is attached – 

 

3. Create SSL connection using certificate within the .keystore 

6.2.1.3 Java /other application Client  

1. Once you have the .keystore file and passphrase file, write code to read .keystore file by providing 
.keystore file path and using the passphrase. Sample java code is attached - 

 

2. Create SSL connection using certificate within the .keystore. 

https://developer.apple.com/library/ios/documentation/NetworkingInternet/Conceptual/RemoteNotificationsPG/Chapters/ProvisioningDevelopment.html
https://developer.apple.com/library/ios/documentation/NetworkingInternet/Conceptual/RemoteNotificationsPG/Chapters/ProvisioningDevelopment.html
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6.3 Appendix C – Mutual SSL 

 
For external partners who are advised to communicate over mutual SSL- A unique client certifiate will be provided 
to each partner with cert key. App will have to present the same while calling APIs on Jio API Platform. 

6.4 Appendix D – Developer FAQs 

 

1. On invoking the API, the application gets a response that says “Invalid API Key Error”. What could be the 
reason for this error? 

Resolution - This can happen due to two reasons  

a) Either the API is not assigned to your application. Please ensure that the API for which you are getting 
this error is assigned to your application.  

b) The API key used while invocation is incorrect. Please check the API key shown against your 
application and ensure the same is being used while consuming the APIs. 

 

2. API name is not getting displayed in the API drop down list of your applications. 
 
Resolution - This typically happens when either API is not assigned to your organization or it is already 
added to your application. 

 

3. On invocation of API, the calling app gets an error “Please Provide API Key Error”. 
 
Resolution - Please make sure you are passing API key in header parameter. 

                             Example: X-API-Key : l7xxd7xxxxxxxxxxxxxxxxxxxxx (Note it is case sensitive) 

 

4. I have forgotton my password, how do I retrieve it from the API developer portal?  
 
Resolution. You can use Forgot Password link given in the Login window. Valid users will receive an 
email with further instruction about how to generate new password. 

 

5. While logging in, I am getting “No user found with provided credentials” error 
 
Resolution. Please contact the Developer portal admin for this issue. This happens especially when user 
credentials are disabled. 

 

6. After successful sign-up, I was trying to login but got a message “Account Disabled” 
 
Resolution. Please contact the Developer portal admin for this issue. This happens when user account is 
not yet approved. 

 
 


